Genel Bakış

Koleksiyonlar ile düzeninizi koruyun İçeriği tercihlerinize göre kaydedin ve kategorilere ayırın.
Platform seçin: Android iOS JavaScript

Giriş

iOS için Haritalar SDK'sı ile uygulamanıza Google Haritalar verilerini temel alan haritalar ekleyebilirsiniz. SDK; Google Haritalar sunucularına erişimi, harita görünümünü ve tıklama, sürükleme gibi kullanıcı hareketlerine verilen yanıtları otomatik olarak yönetir. Haritanıza işaretçiler, çoklu çizgiler, zemin bindirmeleri ve bilgi pencereleri de ekleyebilirsiniz. Bu nesneler, harita konumları için ek bilgi sağlar ve kullanıcıların haritayla etkileşimine olanak tanır.

SDK'yı kullanırken Google Haritalar Platformu Hizmet Şartları'na uymanız ve uygulamanızın geçerli yasalara uymasını sağlamanız gerekir. SDK'yı kullanırken her istekle birlikte uygulamanızın adı ve sürümünün, kimlik doğrulama bilgilerinin ve uygulamalar arası anonim bir tanımlayıcının otomatik olarak gönderildiğini unutmayın.

Kitle

Bu kavramsal belge, iOS geliştirme ve nesne odaklı programlama kavramlarına aşina olan kullanıcılar için tasarlanmıştır. Ayrıca, kullanıcıların bakış açısından Google Haritalar'a da aşina olmanız gerekir. iOS için Haritalar SDK'sı ile uygulamaları keşfetmeye ve geliştirmeye başlamanızı sağlamak üzere tasarlanmıştır. Sınıfların ve yöntemlerin belirli ayrıntıları için referans belgelerine de bakabilirsiniz.

Atıf gereksinimleri

Uygulamanızda iOS için Haritalar SDK'sını kullanıyorsanız başvurunuzda yasal uyarılar bölümünün bir parçası olarak ilişkilendirme metnini eklemeniz gerekir. Yasal uyarıların bağımsız bir menü öğesi olarak veya "Hakkında" menü öğesinin bir parçası olarak dahil edilmesi önerilir.

İlişkilendirme metnini, [GMSServices openSourceLicenseInfo] numaralı telefonu arayarak edinebilirsiniz.

Desteklenen platformlar

iOS için Haritalar SDK'sı ile, iOS 13.0 ve sonraki sürümlerini çalıştıran yerel 64 bit cihazları hedefleyen uygulamalar oluşturabilirsiniz. iOS için Haritalar SDK'sı ile uygulama geliştirmek için hedef SDK 13.0 veya üzeri olan en az Xcode 13.0 gerekir. (13.0 veya üzeri bir hedef SDK belirlemek, uygulamanızın iOS 13.0'da çalışmasını engellemez).

Haritalar URL'lerini kullanan uygulamalar için hedef cihazda iOS için Google Haritalar yüklü olmalıdır.

Katı bellek kısıtlamalarının geçerli olması nedeniyle iOS uygulama uzantılarında iOS için Haritalar SDK'sının kullanılması pek mümkün değildir. Örneğin, SDK'nın özel klavyede kullanılması muhtemelen pek mümkün değildir.

Sırada ne var?

iOS için Haritalar SDK'sı ile uygulama oluşturmaya başlamak istiyorsanız önce Google Cloud projenizi ayarlamanız gerekir.