Versions du SDK Places pour Android

Sélectionnez une plate-forme:Android iOS JavaScript

L'équipe Google Maps Platform met régulièrement à jour les SDK en ajoutant des fonctionnalités, en corrigeant les bugs et en améliorant les performances. Cette page explique comment gérer vos dépendances sur les SDK pour mobile.

  • Pour les applications critiques, associez la dernière version ponctuelle de la version majeure que vous utilisez (X.*) et passez chaque année à la nouvelle version majeure.

    À mesure que vous publiez de nouvelles versions de votre application tout au long de l'année, vous pouvez commencer à utiliser des versions ponctuelles plus récentes du SDK Places pour Android. Vous n'aurez pas besoin de mettre à jour votre application, car les nouvelles versions ponctuelles sont rétrocompatibles.

    Avantages :

    • Si vous découvrez des problèmes dans le SDK Places pour Android, les correctifs seront fournis de manière rétrocompatible pendant 12 mois après la publication initiale de la version majeure, conformément à la Règle concernant la compatibilité mobile. Vous n'aurez pas besoin de passer en urgence à une version du SDK incompatible pour profiter des correctifs.
    • Les dernières améliorations et fonctionnalités sont faciles à adopter si votre application est déjà basée sur la dernière version.
    • Les mises à jour incrémentielles annuelles vers la dernière version majeure du SDK peuvent nécessiter moins de travail pour adapter, réécrire et tester votre application, plutôt que de gérer les modifications antérieures incompatibles introduites dans plusieurs versions majeures.

  • Pour les applications non critiques, associez une version corrigée. Lorsque vous recevez un avis d'abandon concernant cette version corrigée, vous disposez de 12 mois pour mettre à disposition des utilisateurs le code de votre application mis à jour.

    Avantages :

    • Les tâches de maintenance sont moins fréquentes.
    • Les nouvelles versions de votre application restent compatibles plus longtemps avec les appareils des utilisateurs équipés de systèmes d'exploitation mobiles plus anciens (jusqu'à ce que vous deviez passer à une nouvelle version du SDK).

Les propriétaires de projets disposant d'adresses e-mail régulièrement consultées reçoivent des notifications proactives sur les modifications affectant chacun de leurs projets. Informez-vous sur les mises à jour importantes, les abandons et les autres modifications.

Installation

Dans le fichier build.gradle au niveau de l'application, vous devez toujours spécifier une version au lieu d'une plage de préfixes (+) ou latest, car ces préfixes peuvent engendrer des builds imprévisibles et impossibles à reproduire. Le SDK Places pour Android respecte la gestion sémantique des versions, et les nouvelles versions majeures peuvent inclure des modifications destructives. Le niveau d'API minimal accepté est 21.

dependencies {
    implementation(platform("org.jetbrains.kotlin:kotlin-bom:$kotlin_version"))
    implementation 'com.google.android.libraries.places:places:3.3.0'
}

Maintenance et mise à niveau

Android Studio recherche automatiquement les nouvelles versions disponibles et affiche un avertissement lorsqu'une nouvelle version d'une dépendance est disponible. Pour limiter les contraintes techniques, passez à la nouvelle version disponible dès que possible. Si vous passez à une nouvelle version majeure, consultez les notes de version pour découvrir les éventuelles modifications incompatibles avec les versions antérieures et comment mettre à jour votre code.

Les propriétaires de projet Google Cloud doivent vérifier si de nouvelles versions sont disponibles, et ils reçoivent en plus des e-mails qui les avertissent en cas de modifications incompatibles avec les versions antérieures qui peuvent avoir un impact sur leurs projets. Pour recevoir des notifications proactives sur ces modifications, attribuez le rôle de propriétaire à une adresse e-mail que vous consultez régulièrement, et ce pour chacun de vos projets.

Si vous passez du SDK Places pour Android version 3.2.0 ou antérieure

Aucune migration n'est nécessaire pour passer au nouveau SDK. Il vous suffit de:

  1. Activez l'API Places (Nouveau) sur la clé API utilisée dans votre application. Si vous utilisez à la fois le SDK Places pour Android et le SDK Places pour Android (Nouveau), nous vous recommandons de créer une clé API distincte pour chaque version d'API. Pour en savoir plus, consultez la page Utiliser des clés API.
  2. Dans la section dependencies de votre fichier build.gradle au niveau du module, mettez à jour la dépendance places et ajoutez la dépendance kotlin-bom:

      dependencies {
          implementation(platform("org.jetbrains.kotlin:kotlin-bom:1.8.0"))
          implementation 'com.google.android.libraries.places:places:3.3.0'
      }

    Pour en savoir plus sur la dépendance kotlin-bom, consultez la page Utilisation de la dernière version de kotlin-stdlib dans les dépendances transitives.

  3. Mettez à jour votre application existante pour appeler la nouvelle méthode Places.initializeWithNewPlacesApiEnabled() et initialiser votre application. Pour en savoir plus, consultez Initialiser le client de l'API Places.

Vos applications existantes continuent de fonctionner inchangées, mais vous pouvez désormais bénéficier de toutes les nouvelles fonctionnalités du SDK.