Konfigurowanie interfejsu Google Pay API

Zadbaj o dobrą organizację dzięki kolekcji Zapisuj i kategoryzuj treści zgodnie ze swoimi preferencjami.

Wymagania wstępne

Zanim zaczniesz, zapoznaj się z warunkami, które musisz spełnić:

Konfigurowanie projektu

Jeśli nie masz jeszcze środowiska Android Studio, pobierz je stąd i zainstaluj.

Dodawanie zależności

Interfejs Google Pay API jest częścią Usług Google Play, dlatego wystarczy, że zaimportujesz bibliotekę Usług Google Play. Możesz też wybrać interfejsy API, które chcesz skompilować samodzielnie.

Aby zaimportować całą bibliotekę Usług Google Play, odwiedź stronę o konfigurowaniu Usług Google Play.

Jeśli wolisz wybiórczo skompilować tylko te interfejsy API, których potrzebujesz, otwórz plik build.gradle w module aplikacji i dodaj do sekcji zależności ten kod:

dependencies {
    implementation 'com.google.android.gms:play-services-wallet:18.1.3'
    implementation 'com.android.support:appcompat-v7:24.1.1'
}

Każda podana wersja to minimalna wersja wymagana przez najnowszą bibliotekę Google Pay API. Aplikacja może wybrać zależność większą niż powyższa wartość. Aktualne informacje o wersji interfejsu Google Pay API znajdziesz na stronie o konfigurowaniu Usług Google Play, a informacje o bibliotekach pomocy – w artykule o konfigurowaniu bibliotek pomocy.

Modyfikowanie pliku manifestu

Aby włączyć Google Pay w swojej aplikacji, musisz dodać poniższy element meta-data interfejsu Google Pay API do elementu <application> w pliku AndroidManifest.xml Twojego projektu.

<meta-data
    android:name="com.google.android.gms.wallet.api.enabled"
    android:value="true" />