เวอร์ชันไลบรารี

Stay organized with collections Save and categorize content based on your preferences.

ตั้งแต่เวอร์ชัน 15.0.0 เป็นต้นไป ระบบจะดูแลรักษาไลบรารีบริการ Google Play แยกต่างหาก ซึ่งช่วยให้ทีมพัฒนาของห้องสมุดแต่ละแห่งสามารถจัดส่งการแก้ไขและการเพิ่มประสิทธิภาพได้อย่างอิสระและรวดเร็ว คุณติดตามรุ่นล่าสุดสําหรับบริการ Google Play และ Firebase ได้

การจับคู่เวอร์ชันเข้มงวด

เวอร์ชันไลบรารีหนึ่งอาจใช้งานกับเวอร์ชันอื่นของไลบรารีอื่นไม่ได้ ปลั๊กอิน Gradle จํานวนมากให้คําแนะนําเกี่ยวกับเวอร์ชันที่ไม่ตรงกันเหล่านี้เพื่อช่วยรับมือกับสถานการณ์นี้ ตรรกะในปลั๊กอินเหล่านี้คล้ายกับตรรกะในกฎ failOnVersionConflict() สําหรับ ResolutionStrategy ที่เชื่อมโยงกับบริการ Google Play และทรัพยากร Dependency ของ Firebase

ปลั๊กอินสําหรับบริการของ Google

ปลั๊กอิน Google Services Gradle จะตรวจหาบริการ Google Play และไลบรารี Firebase เวอร์ชันที่เข้ากันได้

ปลั๊กอินตัวจับคู่เวอร์ชันแบบสแตนด์อโลน

หากคุณไม่ได้ใช้ปลั๊กอินสําหรับบริการของ Google แต่ยังคงต้องการตรวจสอบทรัพยากร Dependency แบบเข้มงวด ให้ใช้ [strict-version-matcher-plugin] ดูโค้ดของปลั๊กอินนี้ใน GitHub

ข้อมูลโค้ดต่อไปนี้จะแสดงวิธีเพิ่มปลั๊กอิน Gradle

บริการ DSL ของ Kotlin

build.gradle.kts

plugin {
    id("com.google.android.gms.strict-version-matcher-plugin")
}

Groovy DSL

build.gradle

apply plugin: 'com.google.android.gms.strict-version-matcher-plugin'

หากต้องการใช้ปลั๊กอินนี้ คุณจะต้องเพิ่มรายการต่อไปนี้ลงในคลาสเส้นทางบิลด์ของบิลด์ที่ได้มาจากที่เก็บ Maven ของ Google

บริการ DSL ของ Kotlin

build.gradle.kts

classpath("com.google.android.gms:strict-version-matcher-plugin:1.2.4")

Groovy DSL

build.gradle

classpath 'com.google.android.gms:strict-version-matcher-plugin:1.2.4'