Versiones de la biblioteca

Stay organized with collections Save and categorize content based on your preferences.

A partir de la versión 15.0.0, las bibliotecas de los Servicios de Google Play se mantienen de forma individual, lo que permite a los equipos de desarrollo de cada biblioteca enviar correcciones y mejoras de forma independiente y más rápida. Puedes hacer un seguimiento de las versiones más recientes de los Servicios de Google Play y Firebase.

Coincidencia estricta de versiones

Una versión de una biblioteca puede ser incompatible con una versión específica de otra biblioteca. Para ayudar a controlar esta situación, varios complementos de Gradle ofrecen orientación sobre estas discrepancias de versión. La lógica en estos complementos es similar a la lógica en una regla failOnVersionConflict() para una ResolutionStrategy asociada con los Servicios de Google Play y las dependencias de Firebase.

Complemento de servicios de Google

El complemento de Servicios de Google para Gradle busca versiones compatibles de los Servicios de Google Play y las bibliotecas de Firebase.

Complemento de comparador de versiones independiente

Si no usas el complemento de Google Services, pero deseas contar con una verificación de versión estricta de tus dependencias, puedes aplicar el [strict-version-matcher-plugin]. Puedes ver este código del complemento en GitHub.

En el siguiente fragmento de código, se muestra cómo agregar el complemento de Gradle:

DSL de Kotlin

build.gradle.kts.

plugin {
    id("com.google.android.gms.strict-version-matcher-plugin")
}

DSL de Groovy

build.gradle

apply plugin: 'com.google.android.gms.strict-version-matcher-plugin'

Para usar este complemento, también debes agregar lo siguiente a tu classpath buildscript, que se obtuvo del repositorio Maven de Google:

DSL de Kotlin

build.gradle.kts.

classpath("com.google.android.gms:strict-version-matcher-plugin:1.2.4")

DSL de Groovy

build.gradle

classpath 'com.google.android.gms:strict-version-matcher-plugin:1.2.4'